CVE-2026-41323: Kyverno: ServiceAccount token exposure via apiCall service URL
CVE-2026-41323 affects Kyverno, where the apiCall feature in ClusterPolicy attaches the admission controller ServiceAccount token to outgoing HTTP requests without validating the destination URL. The record states that a stolen token can lead to full cluster compromise because this ServiceAccount can patch webhook configurations. The description says versions 1.18.0-rc1, 1.17.2-rc1 and 1.16.4 fix the issue.
Overview
CVE-2026-41323 is a weakness in Kyverno's apiCall feature within ClusterPolicy resources. According to the record, the feature attaches the admission controller ServiceAccount token to outgoing HTTP requests, and the service URL is not validated, so the destination can be any host. The CWE classification in the record is CWE-200, Exposure of Sensitive Information. The GitHub advisory is available at GHSA-f9g8-6ppc-pqq4 and the NVD entry at NVD CVE-2026-41323.
Impact
- The record states that the token is sent to whatever server the service URL points to, which can expose the credential to a party outside the cluster.
- The record states that the admission controller ServiceAccount can patch webhook configurations, so a stolen token could be used to escalate to full cluster compromise.
- The NVD and GitHub scores are 9.1 and 8.1 respectively (CVSS 3.1); the record's severity field is critical.
Affected products and versions
- Product in the record: Kyverno Kyverno.
- The record lists these ranges: before 1.16.4; from 1.17.0 up to before 1.17.2; and from 1.17.0-rc1 up to before 1.17.2-rc1.
- The description names 1.18.0-rc1, 1.17.2-rc1 and 1.16.4 as the patched versions. The record does not list an affected range for the 1.18 branch, so whether earlier 1.18 builds are affected is unknown from the available data.
Exploitation status
- The CISA KEV catalogue entry in the record is not listed, so no confirmed exploitation in the wild can be stated from this record.
- The record gives an SSVC exploitation value of poc and an EPSS probability of 0.00571 with a percentile of 0.46526.
- One reference is tagged Exploit in the record metadata, but the record does not provide exploit details, and this analysis does not describe any.
Remediation and mitigation
- Upgrade Kyverno to a patched version: 1.16.4 for the 1.16 line, 1.17.2 or 1.17.2-rc1 for the 1.17 line, and 1.18.0-rc1 for the 1.18 line, as stated in the description.
- Review ClusterPolicy resources that use apiCall and restrict them to trusted service endpoints until the upgrade is complete.
- Limit the admission controller ServiceAccount permissions to the minimum needed, especially for patching webhook configurations.
- Apply network egress controls so admission controller pods can reach only the endpoints they need.
Detection guidance
- Inventory ClusterPolicy objects that contain apiCall entries and review their service URLs for unexpected external hosts.
- Monitor outbound connections from the Kyverno admission controller pods for destinations outside the expected set.
- Audit changes to ValidatingWebhookConfiguration and MutatingWebhookConfiguration objects, and investigate modifications made by unexpected identities.
Limitations of the available information
- The record does not give the exact technical conditions under which the token is sent, nor any independent verification of the exploitation path.
- The record contains duplicate affected entries that use different notations, so the exact boundary between 1.17.0-rc1 and 1.17.0 is not fully clear from the record alone.
- The EPSS date in the record (2026-10-23) is later than the publication date, which may indicate a data artefact; it should be checked against the live EPSS source.
Frequently asked questions
What is the core problem in CVE-2026-41323?
According to the record, Kyverno's apiCall feature in ClusterPolicy attaches the admission controller ServiceAccount token to outgoing HTTP requests and does not validate the service URL, so the token can be sent to an arbitrary server.
Is this vulnerability confirmed as actively exploited?
No. The record shows the CVE is not listed in the CISA KEV catalogue, so no confirmed exploitation in the wild can be stated from the sources consulted.
Which versions are fixed?
The description says versions 1.18.0-rc1, 1.17.2-rc1 and 1.16.4 patch the issue. Users on the 1.16 line should move to 1.16.4, and users on the 1.17 line should move to 1.17.2 or 1.17.2-rc1.
This analysis was drafted with AI assistance from verified source data and automatically checked against it.