CVE-2022-25860 — Remote code execution in simple-git
Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution (RCE) via the clone(), pull(), push() and listRemote() methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221).
Who exploits it and how urgent it is
A 0–100 score combining confirmed exploitation, ransomware and APT use, public exploits, EPSS and severity.
How the score was calculated
- EPSS 2.7% (30-day exploitation probability)+13
- Technical severity (critical)+10
- CISA SSVC: exploitation "poc"+5
The score orders the patch queue; it does not replace your asset context (internet exposure, criticality, compensating controls).
Triage
Is it exploited, how likely is exploitation, what does it touch, and how severe do the sources call it.
CISA SSVC assessment CISA
Three decision points CISA publishes for the CVEs it assesses (SSVC 2.0.3). A stakeholder decision, not a severity score.
Remediation
Fixes and mitigations documented by the sources — linked to the original advisory.
- Documented patch — github.com (NIST National Vulnerability Database)
- Documented patch — github.com (NIST National Vulnerability Database)
- Npm Simple-git: fixed in version 3.16.0 — github.com (GitHub Security Advisories)
First 24 hours
Ordered from the record’s own fields — exposure first, because you cannot patch what you have not found. A rule-generated starting point.
- Identify exposed assets running the affected vendor/product/version combinations (Simple-git Project Simple-git, Npm Simple-git).
- The attack is network-based and needs no privileges: restrict exposure (ACLs, VPN, WAF) until patched.
- Apply the fixed version or the patch documented under Remediation.
- Search available logs for exploit probes matching the vulnerability class (injection), errors and authentication anomalies.
Affected scope
Vendor, product and versions as the sources word them.
| Vendor | Product | Versions | Status | Source |
|---|---|---|---|---|
| Simple-git Project | Simple-git | < 3.16.0 | Vulnerable | NIST National Vulnerability Database |
| Npm | Simple-git | < 3.16.0 | Vulnerable | GitHub Security Advisories |
Attack characteristics
The CVSS vector, decoded. It describes the attack, not your exposure to it.
Every base score collected
Sources score independently and may disagree; each row says who scored it and under which version.
| Score | Version | Severity | Expl. | Impact | Scored by |
|---|---|---|---|---|---|
| 9.8 | CVSS 3.1 | Critical | 3.9 | 5.9 | nvd@nist.gov via NIST National Vulnerability Database |
| 9.8 | CVSS 3.1 | Critical | — | — | GitHub, Inc. via GitHub Security Advisories |
| 8.1 | CVSS 3.1 | High | 2.2 | 5.9 | report@snyk.io via NIST National Vulnerability Database |
| 8.1 | CVSS 3.1 | High | — | — | snyk via CVE Program (cve.org) e CISA ADP |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (score shown at the top: nvd@nist.gov) Weakness MITRE
Weakness class according to MITRE’s CWE catalog.
EPSS over time FIRST
Oct 26, 2026 → Oct 29, 2026 · 4 reading(s) · max 2.71%
Detection
Read off the CVSS vector and the weakness class. Starting points, not tested rules.
- Prioritize edge telemetry for the network-reachable component (proxy, WAF, IDS/IPS).
- Look for parameters with command/query metacharacters and unexpected child processes of the service.
Timeline
What happened to this CVE, newest first.
- 2026
- Fix documented
- Affected products added · npm/simple-git
- SSVC assessment updated
- Record published
- Fix documented
- Affected products added · simple-git project/simple-git
- CVSS changed · 9.8
- Source status changed · → Modified
- Record created in this database
- 2023
- CVE published
Source activity
Repeated readings are counted rather than listed.
- 2× References added · Oct 26, 2026 – Oct 26, 2026
- 1× Official description updated · Oct 26, 2026 – Oct 26, 2026
References
5 on the record
Elsewhere on this site
Related CVEs (same products)
- Critical CVE-2026-102827 simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) Sep 29, 2026
- Critical CVE-2026-102828 simple-git unsafe-operation guard does not block trailer command configuration Sep 29, 2026
- High CVE-2026-102826 simple-git allows command execution through unblocked Git configuration includes Sep 29, 2026
- Critical CVE-2026-6951 Code Injection in Simple-git Project Simple-git Apr 25, 2026
- High CVE-2026-28291 simple-git has Command Execution via Option-Parsing Bypass Apr 13, 2026
- Critical CVE-2026-28292 simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE Mar 10, 2026
Not in any source we poll
Listed rather than left blank: an empty field and an unmeasured one look identical on screen, and only one is a reason to look elsewhere.
- No confirmed IOCs, IP addresses, domains, file hashes, or malware artifacts supplied.
- No organization-specific asset inventory, compensating-control status, or patch deployment evidence supplied.
- No exploit packet captures, log samples, or incident case IDs supplied.
Answered from this record
Text assembled only from the fields above — no additional claims.
What should defenders know first?
CVE-2022-25860 is "Remote code execution in simple-git", rated Critical. It affects Simple-git (Simple-git Project); versions are in the scope table. It is not in CISA KEV, which does not rule out exploitation. CVSS 9.8 describes technical severity. EPSS 2.71% estimates the probability of exploitation in 30 days; neither replaces your asset context. First verify whether exposed or business-critical assets run the affected versions, apply vendor fixes or mitigations, and preserve logs for review.
Comments
Moderated technical discussion. Read the community guidelines.
No comments yet.
Sign in or create an account to comment and suggest corrections.