CVE-2023-28115 — Snappy vulnerable to PHAR deserialization, allowing remote code execution
Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromHtml()` function, it will invoke deserialization. This vulnerability is capable of remote code execution if Snappy is used with frameworks or developer code with vulnerable POP chains. It has been fixed in version 1.4.2.
Who exploits it and how urgent it is
A 0–100 score combining confirmed exploitation, ransomware and APT use, public exploits, EPSS and severity.
How the score was calculated
- EPSS 2.8% (30-day exploitation probability)+13
- Technical severity (critical)+10
- Automatable exploitation (SSVC)+3
The score orders the patch queue; it does not replace your asset context (internet exposure, criticality, compensating controls).
Triage
Is it exploited, how likely is exploitation, what does it touch, and how severe do the sources call it.
CISA SSVC assessment CISA
Three decision points CISA publishes for the CVEs it assesses (SSVC 2.0.3). A stakeholder decision, not a severity score.
Remediation
Fixes and mitigations documented by the sources — linked to the original advisory.
- Documented patch — github.com (NIST National Vulnerability Database)
- Documented patch — github.com (NIST National Vulnerability Database)
- Documented patch — github.com (NIST National Vulnerability Database)
- Composer KnpLabs/knp-snappy: fixed in version 1.4.2 — github.com (GitHub Security Advisories)
First 24 hours
Ordered from the record’s own fields — exposure first, because you cannot patch what you have not found. A rule-generated starting point.
- Identify exposed assets running the affected vendor/product/version combinations (KnpLabs Snappy, Composer KnpLabs/knp-snappy).
- The attack is network-based and needs no privileges: restrict exposure (ACLs, VPN, WAF) until patched.
- Apply the fixed version or the patch documented under Remediation.
- Search available logs for exploit probes matching the vulnerability class (insecure deserialization), errors and authentication anomalies.
Affected scope
Vendor, product and versions as the sources word them.
Attack characteristics
The CVSS vector, decoded. It describes the attack, not your exposure to it.
Every base score collected
Sources score independently and may disagree; each row says who scored it and under which version.
| Score | Version | Severity | Expl. | Impact | Scored by |
|---|---|---|---|---|---|
| 9.8 | CVSS 3.1 | Critical | 3.9 | 5.9 | security-advisories@github.com via NIST National Vulnerability Database |
| 9.8 | CVSS 3.1 | Critical | 3.9 | 5.9 | nvd@nist.gov via NIST National Vulnerability Database |
| 9.8 | CVSS 3.1 | Critical | — | — | GitHub, Inc. via GitHub Security Advisories |
| 9.8 | CVSS 3.1 | Critical | — | — | GitHub_M via CVE Program (cve.org) e CISA ADP |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (score shown at the top: nvd@nist.gov) Weakness MITRE
Weakness class according to MITRE’s CWE catalog.
EPSS over time FIRST
Oct 25, 2026 → Oct 28, 2026 · 4 reading(s) · max 2.76%
Detection
Read off the CVSS vector and the weakness class. Starting points, not tested rules.
- Prioritize edge telemetry for the network-reachable component (proxy, WAF, IDS/IPS).
- Monitor serialized objects in requests and unexpected processes spawned by the runtime.
Timeline
What happened to this CVE, newest first.
- 2026
- Fix documented
- Affected products added · composer/knplabs/knp-snappy
- Affected products added · knplabs/snappy
- SSVC assessment updated
- Record published
- Fix documented
- Affected products added · knplabs/snappy
- CVSS changed · 9.8
- Source status changed · → Modified
- Record created in this database
- 2023
- CVE published
Source activity
Repeated readings are counted rather than listed.
- 2× References added · Oct 25, 2026 – Oct 25, 2026
- 1× Official description updated · Oct 25, 2026 – Oct 25, 2026
References
10 on the record
- github.com/KnpLabs/snappy/security/advisories/GHSA-gq6w-q6wh-jggc
- github.com/KnpLabs/snappy/commit/1ee6360cbdbea5d09705909a150df7963a88efd6
- github.com/KnpLabs/snappy/pull/469
- github.com/KnpLabs/snappy/commit/b66f79334421c26d9c244427963fa2d92980b5d3
- github.com/KnpLabs/snappy/releases/tag/v1.4.2
- nvd.nist.gov/vuln/detail/CVE-2023-28115
- github.com/KnpLabs/snappy/blob/5126fb5b335ec929a226314d40cd8dad497c3d67/src/Knp/
- github.com/FriendsOfPHP/security-advisories/blob/master/knplabs/knp-snappy/CVE-2
- huntr.dev/bounties/0bdddc12-ff67-4815-ab9f-6011a974f48e/
- github.com/advisories/GHSA-gq6w-q6wh-jggc
Elsewhere on this site
Related CVEs (same products)
- Medium CVE-2026-46683 Snappy: SSRF and local file read via the xsl-style-sheet option Jun 10, 2026
- High CVE-2026-46643 Snappy: Binary path is never shell-escaped due to an inverted is_executable check Jun 10, 2026
Not in any source we poll
Listed rather than left blank: an empty field and an unmeasured one look identical on screen, and only one is a reason to look elsewhere.
- No confirmed IOCs, IP addresses, domains, file hashes, or malware artifacts supplied.
- No organization-specific asset inventory, compensating-control status, or patch deployment evidence supplied.
- No exploit packet captures, log samples, or incident case IDs supplied.
Answered from this record
Text assembled only from the fields above — no additional claims.
What should defenders know first?
CVE-2023-28115 is "Snappy vulnerable to PHAR deserialization, allowing remote code execution", rated Critical. It affects Snappy (KnpLabs); versions are in the scope table. It is not in CISA KEV, which does not rule out exploitation. CVSS 9.8 describes technical severity. EPSS 2.76% estimates the probability of exploitation in 30 days; neither replaces your asset context. First verify whether exposed or business-critical assets run the affected versions, apply vendor fixes or mitigations, and preserve logs for review.
Comments
Moderated technical discussion. Read the community guidelines.
No comments yet.
Sign in or create an account to comment and suggest corrections.